Vous utilisez Cegid ou Quadratus comme logiciel de production et vous souhaitez le connecter à Chaintrust ?
Voici comment faire étape par étape.
1. Paramétrage de la connexion
La connexion à l'API Cegid CFE doit être configurée au niveau des paramètres du logiciel de comptabilité de la fiduciaire.
Pour établir la connexion, les utilisateurs doivent renseigner deux champs :
- Un identifiant API
- Un secret API
Ces deux identifiants doivent être générés au préalable en suivant la documentation technique spécifique : Apikey_CFE.pdf.
À savoir : Lors de la création de votre clé API dans CegidLife, Cegid doit créer un conteneur associé à cette clé.
Si les identifiants saisis sont valides, la connexion sera confirmée. L'utilisateur pourra alors accéder à la liste des dossiers connectés.
Pour qu'un dossier soit considéré comme "connecté" et puisse communiquer avec l'API, il doit remplir les conditions suivantes :
- Le logiciel comptable assigné au dossier doit être CEGID, CEGID_11 ou QUADRATUS.
- Le champ "Référence dossier" doit être impérativement rempli.
- Cette référence doit correspondre exactement au code dossier tel qu'il existe sur le logiciel comptable (Cegid ou Quadratus).
En cas d’erreur lors de la première synchronisation
Si vous rencontrez l’erreur ContainerNotFoundInSicSettings lors de la première synchronisation, vous pouvez régénérer votre clé API CFE depuis CegidLife et consulter les ressources Cegid ci-dessous pour plus d’informations sur sa résolution (accessibles uniquement aux clients connectés à CegidLife).
→ Consulter la première ressource Cegid
→ Consulter la seconde ressource Cegid
Documents complémentaires Cegid :
- Apikey_CFE.pdf
- CegidAzureCFE.pdf
- CFE_Automatisation transferts fichiers avec AzureStorage_maj17062022.docx
- QC_asc.pdf
À savoir : Si le problème persiste malgré ces manipulations, nous vous invitons à contacter directement le support téléphonique de Cegid.
Connexion du dossier à Cegid
Pour chaque dossier, il est nécessaire de le connecter à une instance Cegid via le bouton de connexion. Cette étape est obligatoire pour assurer le bon fonctionnement de l’intégration.
Vous pouvez effectuer cette action de trois manières différentes :
a. Depuis l’onglet Plan Comptable
Rendez-vous dans l’onglet “Plan comptable” puis dans “Configuration” cliquez sur “Logiciel” et activez “Connecter le dossier sur l'instance Cegid”.
b. Depuis les paramètres société
Rendez-vous dans l’onglet “Paramètres société” puis dans “Paramètres” et activez “Connecter le dossier sur l'instance Cegid”.
c. Depuis la liste des dossiers connectés en API
Rendez-vous dans l’onglet “Paramètres”, puis cliquez sur “Voir les dossiers connectés”.
Dans la liste des dossiers accessibles sur l’API, activez le bouton de connexion en face du dossier concerné afin de le lier à l’instance Cegid.
2. Envoi des archives par API
Lorsqu'un dossier est correctement connecté, l'utilisateur bénéficie d'une nouvelle fonctionnalité lors de la génération d'une archive depuis l’onglet “Mes écritures”
Une option "Envoyer par API" sera disponible, permettant de transmettre l'archive générée directement au logiciel comptable concerné.
3. Gestion des erreurs
Si une erreur se produit lors de la tentative d'envoi par API, le système affichera un message d'erreur clair à l'utilisateur.
Dans ce cas, vous aurez la possibilité de renvoyer l'archive manuellement. Cette option de renvoi est accessible depuis la page de détails de l'archive qui a échoué.
Association des pièces jointes
Dans certains cas, après l’import manuel d’une archive ZIP dans Cegid :
- les écritures sont bien générées,
- toutes les pièces sont bien présentes dans l’archive,
- mais une seule pièce est rattachée à l’ensemble des écritures importées.
Pour cela, rendez-vous dans Cegid, puis faites un clic droit sur le journal concerné et sélectionnez “Paramétrage du journal”.
Dans l’onglet Caractéristiques, vérifiez le champ « Mode de saisie » : le journal doit être configuré en « Bordereau » et non en « Libre ».
À savoir : Si la modification est impossible, il faudra créer un autre journal.